
        <!doctype html>
        <html lang="en">
            <head>
                <!-- ABCOTV | 592bf9bf6486 | 2794 | 3a89c23e7167fe830eb2e5f068dab7ced2f45eed | Sun, 17 May 2020 23:55:23 GMT -->
                <script type='text/javascript' >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</script>
                <title data-react-helmet="true">North Carolina High School Athletic Association &#x27;Unsung Hero Award&#x27; goes to 3 lifelong Triangle natives - ABC11 Raleigh-Durham</title>
                <meta data-react-helmet="true" name="description" content="Every spring the North Carolina High School Athletic Association awards an unsung hero."/><meta data-react-helmet="true" name="keywords" content="nchsaa, North Carolina High School Athletic Association unsung hero award, steve alford, ted carver, arnold spell"/><meta data-react-helmet="true" name="tags" content="high-school-sports,award,sports"/><meta data-react-helmet="true" name="apple-itunes-app" content="app-id=408441304, affiliate-data=ct=wtvd-smart-banner&amp;pt=302756, app-argument=https://abc11.com/story/6190921"/><meta data-react-helmet="true" property="fb:app_id" content="476025212522972"/><meta data-react-helmet="true" property="fb:pages" content="57780972549"/><meta data-react-helmet="true" property="og:site_name" content="ABC11 Raleigh-Durham"/><meta data-react-helmet="true" property="og:url" content="https://abc11.com/6190921/"/><meta data-react-helmet="true" property="og:title" content="North Carolina High School Athletic Association &#x27;Unsung Hero Award&#x27; goes to 3 lifelong Triangle natives"/><meta data-react-helmet="true" property="og:description" content="The award is going to Steve Alford, Ted Carver and Arnold Spell. The trio serves in a variety of roles for the State Championships in golf, football and basketball with the NCHSAA."/><meta data-react-helmet="true" property="og:image" content="https://cdn.abcotvs.com/dip/images/6191639_051720-wtvd-NCHSSA-award-6PM-video-vid.jpg?w=1600"/><meta data-react-helmet="true" property="og:type" content="article"/><meta data-react-helmet="true" name="twitter:site" content="@ABC11_WTVD"/><meta data-react-helmet="true" name="twitter:creator" content="@ABC11_WTVD"/><meta data-react-helmet="true" name="twitter:url" content="https://abc11.com/6190921/"/><meta data-react-helmet="true" name="twitter:title" content="North Carolina High School Athletic Association &#x27;Unsung Hero Award&#x27; goes to 3 lifelong Triangle natives"/><meta data-react-helmet="true" name="twitter:description" content="The award is going to Steve Alford, Ted Carver and Arnold Spell. The trio serves in a variety of roles for the State Championships in golf, football and basketball with the NCHSAA."/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:image" content="https://cdn.abcotvs.com/dip/images/6191639_051720-wtvd-NCHSSA-award-6PM-video-vid.jpg?w=1600"/><meta data-react-helmet="true" name="twitter:app:name:iphone" content="wtvd"/><meta data-react-helmet="true" name="twitter:app:id:iphone" content="408441304"/><meta data-react-helmet="true" name="twitter:app:name:googleplay" content="wtvd"/><meta data-react-helmet="true" name="twitter:app:id:googleplay" content="com.abclocal.wtvd.news"/><meta data-react-helmet="true" property="article:published_time" content="2020-05-17T22:45:19.000Z"/><meta data-react-helmet="true" property="article:modified_time" content="2020-05-17T22:45:19.000Z"/><meta data-react-helmet="true" property="article:section" content="sports"/><meta data-react-helmet="true" name="title" content="North Carolina High School Athletic Association &#x27;Unsung Hero Award&#x27; goes to 3 lifelong Triangle natives"/><meta data-react-helmet="true" name="medium" content="website"/>

                <meta charSet="utf-8" />
                <meta name="viewport" content="initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
                <meta http-equiv="x-ua-compatible" content="IE=edge,chrome=1" />
                <meta name="robots" content="NOODP,NOYDIR" />
                <meta property="og:locale" content="en_US" />
                <link href="//assets-cdn.abcotvs.net" rel="preconnect" />
                <link href="https://cdn.abcotvs.net/abcotv" rel="preconnect" crossorigin />
                <link rel="stylesheet" href="//assets-cdn.abcotvs.net/abcotv/3a89c23e7167-release-05-13-2020.2/client/css/abcotv.css" />
                <link data-react-helmet="true" rel="shortcut icon" href="https://cdn.abcotvs.net/abcotv/assets/news/wtvd/images/logos/favicon.ico"/><link data-react-helmet="true" rel="manifest" href="//abc11.com/manifest.json"/><link data-react-helmet="true" rel="alternate" href="//abc11.com/feed/" title="ABC11 Raleigh-Durham RSS" type="application/rss+xml"/><link data-react-helmet="true" rel="alternate" href="android-app://com.abclocal.wtvd.news/http/abc11.com/story/6190921"/><link data-react-helmet="true" rel="canonical" href="https://abc11.com/nchsaa-north-carolina-high-school-athletic-association-unsung-hero-award-steve-alford-ted-carver/6190921/"/><link data-react-helmet="true" rel="amphtml" href="https://abc11.com/amp/nchsaa-north-carolina-high-school-athletic-association-unsung-hero-award-steve-alford-ted-carver/6190921/"/>
            </head>
            <body>
                <div id="abcotv"><div id="fitt-analytics"><div class="wrapper"><section class="breaking-news"><div id="breaking-news-handler"><ul id="breaking-news-stories" class="breaking-news-stories collapse"><li class="breaking-news-story 0 on "><div class="breaking-news-content"><div class="arrow"></div><div class="breaking-news-callout"><span class="breaking-news-label">BREAKING NEWS</span><span>LATEST: Durham County COVID-19 near 1,000 mark</span></div></div><div id="breaking-news-share"><div class="breaking-news-button"><a class="AnchorLink button" tabindex="0" href="//abc11.com/health/latest-durham-county-covid-19-near-1000-mark/6190573/">Full Story</a></div></div></li></ul></div><div class="breaking-news-pager "><div class="hr"><hr/></div><ul><li class="on"></li></ul></div></section><section class="nav"><header class="feature-container wtvd"><a class="feature-action" href="//abc11.com/watch/" data-clink="**Filler**"><p>WATCH<span class="feature-watch-live"> <!-- -->VIDEOS</span></p></a><div class="feature-header-container"><div class="feature-search-overlay"></div><div class="feature-search-bar"><form class="form-search frame-search"><input type="text" class="search-bar-input" name="query" placeholder="Search abc11.com" autoComplete="off"/><input type="submit" class="search-btn" value="Search"/></form></div><div class="feature-search-close"></div><div class="feature-header-left"><span class="feature-menu closed"><div class="menu-icon menu-closed"></div></span><a class="feature-logo" href="/" data-clink="**Filler**"><div class="sml-logo"></div><div class="lrg-logo"></div></a></div><div class="feature-header-right"><div class="feature-nav-local" style="max-width:undefinedpx"><div class="local-links"><span><a class="AnchorLink" tabindex="0" href="//abc11.com/raleigh/">Raleigh</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/durham/">Durham</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/fayetteville/">Fayetteville</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/counties/">Surrounding Area</a></span></div></div><a class="feature-local-expand" href="#"></a><div class="feature-border feature-border-one"></div><div class="feature-weather-container weather-desktop"><a href="//abc11.com/weather/"><div class="feature-weather icon-weather_"></div><span class="feature-degrees"></span></a><div class="weather-text-container"><a href="//abc11.com/weather/" class="feature-weather-location"></a><a class="feature-weather-edit">EDIT</a></div></div><div class="feature-border feature-border-two"></div><div class="feature-ux-container"><a class="feature-logged-out login register">Log In</a><div class="feature-search-container"></div></div><div class="feature-border feature-border-three"></div></div></div></header><nav class=""><div class="nav-wrapper"><div class="nav-sections-main-local"><div class="nav-sections-links nav-sections-main"><div class="subnav-search-bar"><form class="form-search frame-search"><input type="text" class="search-bar-input" name="query" placeholder="Search abc11.com" autoComplete="off"/><input type="submit" class="search-btn" value="Search"/></form></div><a class="subnav-main-btn" href="/watch/"><span class="subnav-watch"></span>Watch</a><a class="subnav-main-btn" href="/photos/"><span class="subnav-photos"></span>Photos</a></div><div class="nav-sections-links nav-sections-local subnav-local"><div class="nav-sections-header"><a class="nav-section-name" data-clink="**Filler**">Local News<!-- --> <div class="expand-arrow-light"></div></a><div><span><a class="AnchorLink" tabindex="0" href="//abc11.com/raleigh/">Raleigh</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/durham/">Durham</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/fayetteville/">Fayetteville</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/counties/">Surrounding Area</a></span></div></div></div></div><div class="nav-sections-links nav-sections-categories subnav-categories"><div class="nav-sections-header"><a class="nav-section-name" data-clink="**Filler**">Categories<!-- --> <div class="expand-arrow-light"></div></a><div class="nav-sections-categories-1"><span><a class="AnchorLink" tabindex="0" href="//abc11.com/weather/">Weather</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/traffic/">Traffic</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/us-world/">U.S. &amp; World</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/state/">North Carolina</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/iteam/">I-Team</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/troubleshooter/">Troubleshooter</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/entertainment/">Entertainment</a></span></div><div class="nav-sections-categories-2"><span><a class="AnchorLink" tabindex="0" href="//abc11.com/weather/">Weather</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/localish/">LOCALISH</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/sports/">Sports</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/politics/">Politics</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/health/">Health and Coronavirus</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/scienceclub/">Science Club</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/sweepstakes/">Sweepstakes</a></span></div></div></div><div class="nav-sections-community-shows nav-sections-station-info"><div class="nav-sections-links nav-sections-community subnav-community"><div class="nav-sections-header"><a class="nav-section-name" data-clink="**Filler**">Station Info<!-- --> <div class="expand-arrow-light"></div></a><div><span><a class="AnchorLink" tabindex="0" href="//abc11.com/about/">About ABC11</a></span><span><a class="AnchorLink" tabindex="0" href="https://abc11.com/share/">Send us your photos &amp; videos</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/together/">ABC11 Together</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/influencers/">ABC11 Influencers</a></span><span><a class="AnchorLink" tabindex="0" href="https://abc11.com/community/calendar/">Events Calendar</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/tvlistings/">TV Listings</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/jobs/">Jobs</a></span></div></div></div></div><div class="nav-sections-community-shows"><div class="nav-sections-links nav-sections-shows subnav-shows"><div class="nav-sections-header"><a class="nav-section-name" data-clink="**Filler**">shows<!-- --> <div class="expand-arrow-light"></div></a><div><span><a class="AnchorLink" tabindex="0" href="//abc11.com/live/">ABC11 Live Newscasts</a></span><span><a class="AnchorLink" tabindex="0" href="//abc11.com/perspectives/">ABC11 Perspectives</a></span><span><a class="AnchorLink" tabindex="0" href="https://www.laff.com/">LAFF</a></span></div></div></div></div><div class="nav-promos-follow"><div class="frame-social nav-social"><div class="frame-social-action">Follow Us:</div><div class="frame-social-icons"><a class="follow-btn follow-btn--facebook" href="https://facebook.com/abc11" target="_self"></a><a class="follow-btn follow-btn--twitter" href="https://twitter.com/ABC11_WTVD" target="_self"></a><a class="follow-btn follow-btn--instagram" href="https://www.instagram.com/abc11_wtvd/" target="_self"></a><a class="follow-btn follow-btn--email" href="/newsletters" target="_self"></a></div></div></div></div></nav><div class="profile-drop-down has-breaking"><div class="profile-name">Welcome, </div><div class="profile-edit">Your Account</div><div class="profile-logout">Log Out</div></div></section><main role="main" class="story"><div data-box-type="fitt-adbox-leaderboard1"><div class="Ad ad-slot" data-slot-type="leaderboard1" data-slot-kvps="pos=leaderboard1"></div></div><div class="content"><div class="side-left"><div class="StickyContainer" data-sticky-parent="true"><div class="" data-sticky="true"><div class="social-icons left-outer"><ul class="social"><li class="facebook"><a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fabc11.com%2Fsports%2Fnchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives%2F6190921%2F" target="_blank"><span class="text-callout">Share</span></a></li><li class="twitter"><a href="http://twitter.com/intent/tweet?url=https%3A//abc11.com/sports/nchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives/6190921/&amp;text=North%20Carolina%20High%20School%20Athletic%20Association%20%27Unsung%20Hero%20Award%27%20goes%20to%203%20lifelong%20Triangle%20natives&amp;via=ABC11_WTVD" target="_blank"><span class="text-callout">Tweet</span></a></li><li class="email"><a href="mailto:?subject=North%20Carolina%20High%20School%20Athletic%20Association%20%27Unsung%20Hero%20Award%27%20goes%20to%203%20lifelong%20Triangle%20natives&amp;body=The%20award%20is%20going%20to%20Steve%20Alford%2C%20Ted%20Carver%20and%20Arnold%20Spell.%20The%20trio%20serves%20in%20a%20variety%20of%20roles%20for%20the%20State%20Championships%20in%20golf%2C%20football%20and%20basketball%20with%20the%20NCHSAA.%20-%20https%3A//abc11.com/sports/nchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives/6190921/" target="_blank"><span class="text-callout">Email</span></a></li></ul></div></div></div></div><div class="main-wide main-left"><section class="lead-story inner post"><div class="taxonomy"><a href="/tag/sports/">sports</a></div><h1 class="headline">North Carolina High School Athletic Association 'Unsung Hero Award' goes to 3 lifelong Triangle natives</h1><div class="originBylineContainer"><div class="global-caption wtvd image-caption byline"><div class="origin-logo wtvd origin-image byline"><span class="wtvd byline">WTVD</span></div></div><div class="wtvd byline">By <span itemscope="" itemType="https://schema.org/Person"><meta itemProp="url" content="http://abc11.com/about/newsteam/bridget-condon"/><meta itemProp="affiliation"/><meta itemProp="jobTitle" content="Staff"/><a href="http://abc11.com/about/newsteam/bridget-condon" itemProp="name" rel="author">Bridget Condon</a></span></div></div><time class="meta lastmodified"> </time><div class="social-icons horizontal"><ul class="social"><li class="share-text">Share:</li><li class="facebook"><a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fabc11.com%2Fsports%2Fnchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives%2F6190921%2F" target="_blank"><span class="text-callout">Share</span></a></li><li class="twitter"><a href="http://twitter.com/intent/tweet?url=https%3A//abc11.com/sports/nchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives/6190921/&amp;text=North%20Carolina%20High%20School%20Athletic%20Association%20%27Unsung%20Hero%20Award%27%20goes%20to%203%20lifelong%20Triangle%20natives&amp;via=ABC11_WTVD" target="_blank"><span class="text-callout">Tweet</span></a></li><li class="email"><a href="mailto:?subject=North%20Carolina%20High%20School%20Athletic%20Association%20%27Unsung%20Hero%20Award%27%20goes%20to%203%20lifelong%20Triangle%20natives&amp;body=The%20award%20is%20going%20to%20Steve%20Alford%2C%20Ted%20Carver%20and%20Arnold%20Spell.%20The%20trio%20serves%20in%20a%20variety%20of%20roles%20for%20the%20State%20Championships%20in%20golf%2C%20football%20and%20basketball%20with%20the%20NCHSAA.%20-%20https%3A//abc11.com/sports/nchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives/6190921/" target="_blank"><span class="text-callout">Email</span></a></li></ul></div><div class="top-media headline-list-item type-video"><div class="featured-media video type-videoClip"><div class=""><div class="video-schema" itemProp="video" itemscope="" itemType="https://schema.org/VideoObject"><meta itemProp="name" content="North Carolina High School Athletic Association &#x27;Unsung Hero Award&#x27; goes to 3 lifelong Triangle natives"/><meta itemProp="description" content="-"/><meta itemProp="thumbnailUrl" content="https://cdn.abcotvs.com/dip/images/6191639_051720-wtvd-NCHSSA-award-6PM-video-vid.jpg"/><meta itemProp="contentURL" content="https://content.uplynk.com/ext/f05837c508c44712aa7129d531f7dbe6/051720-wtvd-NCHSSA-award-6PM-video-vid.m3u8?ad._v=2&amp;ad=wtvd_video&amp;ad.preroll=&amp;ad.fill_slate=1&amp;ad.ametr=1"/><meta itemProp="uploadDate" content="2020-05-17T22:44:47Z"/></div></div></div></div></section><div class="story-body-wrapper post"><div class="mini-side-left"><div class="StickyContainer" data-sticky-parent="true"><div class="" data-sticky="true"><div class="social-icons left-inner"><ul class="social"><li class="share-text">Share:</li><li class="facebook"><a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fabc11.com%2Fsports%2Fnchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives%2F6190921%2F" target="_blank"><span class="text-callout">Share</span></a></li><li class="twitter"><a href="http://twitter.com/intent/tweet?url=https%3A//abc11.com/sports/nchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives/6190921/&amp;text=North%20Carolina%20High%20School%20Athletic%20Association%20%27Unsung%20Hero%20Award%27%20goes%20to%203%20lifelong%20Triangle%20natives&amp;via=ABC11_WTVD" target="_blank"><span class="text-callout">Tweet</span></a></li><li class="email"><a href="mailto:?subject=North%20Carolina%20High%20School%20Athletic%20Association%20%27Unsung%20Hero%20Award%27%20goes%20to%203%20lifelong%20Triangle%20natives&amp;body=The%20award%20is%20going%20to%20Steve%20Alford%2C%20Ted%20Carver%20and%20Arnold%20Spell.%20The%20trio%20serves%20in%20a%20variety%20of%20roles%20for%20the%20State%20Championships%20in%20golf%2C%20football%20and%20basketball%20with%20the%20NCHSAA.%20-%20https%3A//abc11.com/sports/nchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives/6190921/" target="_blank"><span class="text-callout">Email</span></a></li></ul></div></div></div></div><div class="story-body-container"><section class="story-body inner"><div class="body-text"> Every spring, the North Carolina High School Athletic Association awards an unsung hero.<br><br>"Once they got involved in helping us with our championship, they just wanted to come back," said NCHSAA commissioner, Que Tucker. "They're always friendly, they have a willing spirit, and they just come with that smile on their faces ready and willing to do whatever we asked them to do."<br><div class="adRectangle-pos-small-inline" data-set="adAppend"></div><br>This spring the award is going to three men, Steve Alford, Ted Carver and Arnold Spell.<br><br>"It's fun for us," Alford said. "We enjoy it. And you know, it's not something we expect to give you recognition for But it sure is nice that they did."<br><br>"You take 100 counties in North Carolina and they thought enough of us to recognize," said Spell. "That's quite an honor."<br><br>Arnold and Steve are both Durham natives and Ted from Roxboro have been around the association for most of their lives. The trio serves in a variety of roles for the State Championships in golf, football and basketball with the NCHSAA.<br><br>"I think what I get out of it is the fact that there's so many great student athletes in North Carolina," Alford said. "I'm not just talking about physical, I'm talking about they're good people. You know, I mean, and we meet new ones each year. When we go to championships and this is fun to be around, it really is. It keeps me young. Not that I'm old, but it keeps me young."<br><br>"We get to see the best of the best you know, we're always working State Championships and the kids are so great," Spell said. "The parents are great. I have a relatively busy job. And when I go to Southern Pines to work a golf tournament, or I go to Chapel Hill, Raleigh on a Saturday to work State Championships. Everything's gone. Just don't have to worry about any of the day to day stuff.<br><div class="adRectangle-pos-small-inline" data-set="adAppend"></div><br>Typically the unsung hero award is handed out among other NCHSAA awards each May at the Smith Center.<br><br>"This year obviously because of COVID-19 we could not do that it does not diminish the role that they've played and how special we think that they are," said Tucker.<br><br><b><a href="https://abc11.com/coronavirus/">FULL CORONAVIRUS COVERAGE</a></b><br><br>The men said they look forward to hopefully many more years to come with the NCHSAA<br><br>"I'm not a member of a civic club or anything like that," Spell said. "It's kind of my release. I really, really enjoy it."<br><br>"As long as I'm still able to get up and go and they'll still have me, I'll still be there," Alford said. <div class="report-typo">
            <a target="_blank" rel="nofollow" href="/extras/reporttypo?url=https://abc11.com/sports/nchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives/6190921/">Report a correction or typo</a>
        </div></div><div class="taxonomy"><div class="story-taxonomy"><strong>Related topics:</strong><br/><a class="button" href="/topic/sports/">sports</a><a class="button" href="/place/raleigh/">raleigh</a><a class="button" href="/place/chapel-hill/">chapel hill</a><a class="button" href="/place/durham/">durham</a><a class="button" href="/place/roxboro/">roxboro</a><a class="button" href="/tag/high-school-sports/">high school sports</a><a class="button" href="/tag/award/">award</a><a class="button" href="/tag/sports/">sports</a></div></div><div class="social-icons horizontal"><ul class="social"><li class="share-text">Share:</li><li class="facebook"><a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fabc11.com%2Fsports%2Fnchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives%2F6190921%2F" target="_blank"><span class="text-callout">Share</span></a></li><li class="twitter"><a href="http://twitter.com/intent/tweet?url=https%3A//abc11.com/sports/nchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives/6190921/&amp;text=North%20Carolina%20High%20School%20Athletic%20Association%20%27Unsung%20Hero%20Award%27%20goes%20to%203%20lifelong%20Triangle%20natives&amp;via=ABC11_WTVD" target="_blank"><span class="text-callout">Tweet</span></a></li><li class="email"><a href="mailto:?subject=North%20Carolina%20High%20School%20Athletic%20Association%20%27Unsung%20Hero%20Award%27%20goes%20to%203%20lifelong%20Triangle%20natives&amp;body=The%20award%20is%20going%20to%20Steve%20Alford%2C%20Ted%20Carver%20and%20Arnold%20Spell.%20The%20trio%20serves%20in%20a%20variety%20of%20roles%20for%20the%20State%20Championships%20in%20golf%2C%20football%20and%20basketball%20with%20the%20NCHSAA.%20-%20https%3A//abc11.com/sports/nchsaa-unsung-hero-award-goes-to-3-lifelong-triangle-natives/6190921/" target="_blank"><span class="text-callout">Email</span></a></li></ul></div><div class="meta">Copyright © 2020 WTVD-TV. All Rights Reserved.</div></section></div></div><div class="side-wide-inner" data-set="right-sidebar-content"></div></div><div class="side-wide side-right" data-set="right-sidebar-content"><div class="side1"><div data-box-type="fitt-adbox-halfpage"><div class="Ad adRectangle-pos-medium ad-slot" data-slot-type="halfpage" data-slot-kvps="pos=halfpage"></div></div><section class="featuredTag headlines-list inner"><div class="section-header"><div>SPORTS</div> </div><div class="top-stories-expanded"><div class="headlines-images"><div class="headline-list-item has-image" data-media="video"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/sports/​phyllis-george-female-sportscasting-pioneer-dies-at-70/6189586/"><div class="image dynamic-loaded" data-imgsrc="https://cdn.abcotvs.com/dip/images/6189590_051620-wabc-ap-phyllisgeorge-img.jpg" data-imgalt="Phyllis George, the former Miss America who became a female sportscasting pioneer on CBS&#x27;s &quot;The NFL Today,&quot; has died. She was 70." data-topic="sports" data-dynamic="https://cdn.abcotvs.com/dip/images/6189590_051620-wabc-ap-phyllisgeorge-img.jpg"><img class="dynamic-img" src="https://cdn.abcotvs.com/dip/images/6189590_051620-wabc-ap-phyllisgeorge-img.jpg?w=630&amp;r=16%3A9"/></div><div class="headline">​Phyllis George, female sportscasting pioneer, dies at 70</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-1 has-image" data-media="video"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/sports/miracle-league-keeps-dunk-day-alive-with-online-donations/6188652/"><div class="image dynamic-loaded" data-imgsrc="https://cdn.abcotvs.com/dip/images/6189511_051620-wtvd-Miracle-League-6PM-video-vid.jpg" data-imgalt="Even without a season this spring, the league is asking players, coaches and volunteers to raise money online." data-topic="sports" data-dynamic="https://cdn.abcotvs.com/dip/images/6189511_051620-wtvd-Miracle-League-6PM-video-vid.jpg"><img class="dynamic-img" src="https://cdn.abcotvs.com/dip/images/6189511_051620-wtvd-Miracle-League-6PM-video-vid.jpg?w=630&amp;r=16%3A9"/></div><div class="headline">Miracle League keeps &#x27;Dunk Day&#x27; alive with online donations</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-2 has-image" data-media="image"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/giants-baker-turns-himself-in-to-police-on-armed-robbery-charges/6188894/"><div class="image dynamic-loaded" data-imgsrc="https://cdn.abcotvs.com/dip/images/6183588_051420-wabc-deandre-baker-img.jpg" data-imgalt="FILE -- New York Giants cornerback Deandre Baker (27) during an NFL football game against the Minnesota Vikings on Sunday, Oct 6, 2019, in East Rutherford, N.J." data-topic="crime-safety" data-dynamic="https://cdn.abcotvs.com/dip/images/6183588_051420-wabc-deandre-baker-img.jpg"><img class="dynamic-img" src="https://cdn.abcotvs.com/dip/images/6183588_051420-wabc-deandre-baker-img.jpg?w=630&amp;r=16%3A9"/></div><div class="headline">Giants&#x27; Baker turns himself in to police on armed robbery charges</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-3 has-image" data-media="video"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/nfl-players-accused-of-armed-robbery-at-south-florida-party/6184682/"><div class="image dynamic-loaded" data-imgsrc="https://cdn.abcotvs.com/dip/images/6183588_051420-wabc-deandre-baker-img.jpg" data-imgalt="An arrest warrant for armed robbery has been issued for New York Giants cornerback Deandre Baker in Florida." data-topic="crime-safety" data-dynamic="https://cdn.abcotvs.com/dip/images/6183588_051420-wabc-deandre-baker-img.jpg"><img class="dynamic-img" src="https://cdn.abcotvs.com/dip/images/6183588_051420-wabc-deandre-baker-img.jpg?w=630&amp;r=16%3A9"/></div><div class="headline">NFL players accused of armed robbery at South Florida party</div><time class="meta lastmodified"> </time></a></div></div></div></section><section class="cnnvan inner"><div class="section-header"><div>More Videos</div> </div><div id="vembaModule" data-vemba-zone="548735" data-category="Sports"></div><div class="meta text-center">From CNN Newsource affiliates</div></section><section class="top-stories headlines-list inner"><div class="section-header"><div>TOP STORIES</div> </div><div class="top-stories-expanded"><div class="headlines-images"><div class="headline-list-item has-image" data-media="playlist"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/health/latest-durham-county-covid-19-near-1000-mark/6190573/"><div class="image dynamic-loaded" data-imgsrc="https://cdn.abcotvs.com/dip/images/6084268_COVID-19-LATEST.jpg" data-imgalt="coronavirus nc, covid--19 north carolina" data-topic="health" data-dynamic="https://cdn.abcotvs.com/dip/images/6084268_COVID-19-LATEST.jpg"><img class="dynamic-img" src="https://cdn.abcotvs.com/dip/images/6084268_COVID-19-LATEST.jpg?w=630&amp;r=16%3A9"/></div><div class="headline">LATEST: Durham County COVID-19 near 1,000 mark</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-1 has-image" data-media="video"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/weather/tropical-storm-arthur-could-impact-part-of-nc-coast-monday/6189212/"><div class="image dynamic-loaded" data-imgsrc="https://cdn.abcotvs.com/dip/images/6191602_051720-wtvd-tropical-storm-arthur-6PM-video-vid.jpg" data-imgalt="As the first tropical storm of the season, Arthur, approaches the Carolina coast, Gov. Cooper is now urging people to remain aware of the threat that the storm could bring." data-topic="weather" data-dynamic="https://cdn.abcotvs.com/dip/images/6191602_051720-wtvd-tropical-storm-arthur-6PM-video-vid.jpg"><img class="dynamic-img" src="https://cdn.abcotvs.com/dip/images/6191602_051720-wtvd-tropical-storm-arthur-6PM-video-vid.jpg?w=630&amp;r=16%3A9"/></div><div class="headline">Tropical Storm Arthur could impact part of NC coast Monday</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-2 has-image" data-media="video"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/society/nc-churches-welcome-back-congregations-on-sunday/6191335/"><div class="image dynamic-loaded" data-imgsrc="https://cdn.abcotvs.com/dip/images/6191730_TCC6PM.png" data-imgalt="While the Holy Name of Jesus Cathedral and other houses of worship followed Cooper&#x27;s order and had services outside, the Triangle Christian Center in Raleigh filled indoor pews with no social distancing." data-topic="society" data-dynamic="https://cdn.abcotvs.com/dip/images/6191730_TCC6PM.png"><img class="dynamic-img" src="https://cdn.abcotvs.com/dip/images/6191730_TCC6PM.png?w=630&amp;r=16%3A9"/></div><div class="headline">NC churches welcome back congregations on Sunday</div><time class="meta lastmodified"> </time></a></div></div><div class="top-stories-more headlines-noimages single-line"><div class="headline-list-item no-image" data-media="post"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/food/nash-county-farm-donates-thousands-of-eggs-to-local-food-pantries/6190584/"><div class="headline">Nash County farm donates thousands of eggs to local food pantries</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-1 no-image" data-media="post"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/man-found-shot-several-times-in-fayetteville/6190551/"><div class="headline">Man found shot several times in Fayetteville</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-2 no-image" data-media="post"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/man-accused-of-killing-wife-blaming-disappearance-on-covid-19/6190800/"><div class="headline">Man accused of killing wife, blaming disappearance on COVID-19</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-3 no-image" data-media="post"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/health/covid-toes-what-to-do-if-you-see-red-sore-swellings-on-feet/6190990/"><div class="headline">&#x27;COVID toes&#x27;: What to do if you see red, sore swellings on feet</div><time class="meta lastmodified"> </time></a></div></div></div><a class="AnchorLink show-button-more button button-block" tabindex="0">Show More <div class="expand-arrow"></div></a><div class="top-stories-collapsed"><div class="top-stories-more headlines-noimages single-line"><div class="headline-list-item no-image" data-media="post"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/religion/church-service-canceled-heres-a-sunday-message/6190625/"><div class="headline">Church service canceled? Here&#x27;s a Sunday message</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-1 no-image" data-media="post"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/multiple-firefighters-injured-after-explosion-in-downtown-la/6189711/"><div class="headline">Multiple firefighters injured after explosion in Downtown LA</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-2 no-image" data-media="post"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/body-found-in-shallow-waters-of-carolina-beach/6189657/"><div class="headline">Body found in shallow waters of Carolina Beach</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-3 no-image" data-media="post"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/hundreds-demand-justice-for-ahmaud-arbery-call-for-resignation-of-das-at-georgia-rally/6190556/"><div class="headline">Hundreds demand justice for Ahmaud Arbery, call for resignation of DAs at Georgia rally</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-4 no-image" data-media="post"><a class="AnchorLink" tabindex="0" target="_self" href="//abc11.com/sports/​phyllis-george-female-sportscasting-pioneer-dies-at-70/6189586/"><div class="headline">​Phyllis George, female sportscasting pioneer, dies at 70</div><time class="meta lastmodified"> </time></a></div></div><a class="AnchorLink button button-block" tabindex="0" href="/news/">More <!-- -->TOP STORIES News<div class="arrow-blue arrow-pos-right"></div></a></div></section></div></div><div class="clear"></div></div></main><footer class="footer" role="contentinfo"><div class="footer-searchsocial"><div class="footer-brand desktop"><div class="footer-brand-logo" lpos="footer_logo"><a href="/"><img src="https://cdn.abcotvs.net/abcotv/static/wtvd/logos/wtvd_logo_2x.png" alt="ABC11 Raleigh-Durham"/></a></div></div><section class="footer-smallnav"><ul><li><a href="/">Home</a></li><li><a href="/weather/">AccuWeather</a></li><li><a href="/traffic/">Traffic</a></li><li class=""><a class="footer-smallnav-header">Local News<div class="expand-arrow-light"></div></a><ul><a href="/raleigh/">Raleigh</a><a href="/durham/">Durham</a><a href="/fayetteville/">Fayetteville</a><a href="/counties/">Surrounding Area</a></ul></li><li class=""><a class="footer-smallnav-header">Categories<div class="expand-arrow-light"></div></a><ul><a href="/watch/">Watch</a><a href="/photos/">Photos</a><a href="/us-world/">U.S. &amp; World</a><a href="/state/">North Carolina</a><a href="/iteam/">I-Team</a><a href="/troubleshooter/">Troubleshooter</a><a href="/entertainment/">Entertainment</a></ul></li><li class=""><a class="footer-smallnav-header">Station Info<div class="expand-arrow-light"></div></a><ul><a href="/about/">About ABC11</a><a href="https://abc11.com/share/">Send us your photos &amp; videos</a><a href="/together/">ABC11 Together</a><a href="/influencers/">ABC11 Influencers</a><a href="https://abc11.com/community/calendar/">Events Calendar</a><a href="/tvlistings/">TV Listings</a><a href="/jobs/">Jobs</a></ul></li><li class=""><a class="footer-smallnav-header">Shows<div class="expand-arrow-light"></div></a><ul><a href="/live/">ABC11 Live Newscasts</a><a href="/perspectives/">ABC11 Perspectives</a><a href="https://www.laff.com/">LAFF</a></ul></li><li><a href="/apps/">Apps</a></li></ul></section><div class="footer-brand mobile"><div class="footer-brand-logo" lpos="footer_logo"><a href="/"><img src="https://cdn.abcotvs.net/abcotv/static/wtvd/logos/wtvd_logo_2x.png" alt="ABC11 Raleigh-Durham"/></a></div></div><div class="clear"></div><div class="frame-social"><div class="frame-social-action">Follow Us:</div><div class="frame-social-icons"><a class="follow-btn follow-btn--facebook" href="https://facebook.com/abc11" target="_self"></a><a class="follow-btn follow-btn--twitter" href="https://twitter.com/ABC11_WTVD" target="_self"></a><a class="follow-btn follow-btn--instagram" href="https://www.instagram.com/abc11_wtvd/" target="_self"></a><a class="follow-btn follow-btn--email" href="/newsletters" target="_self"></a></div></div></div><div class="footer-sections"><div class="footer-sections-col1"><div class="footer-sections-group"><a href="//abc11.com/">Home</a><a href="//abc11.com/weather/">Weather</a><a href="//abc11.com/traffic/">Traffic</a><a href="//abc11.com/watch/">Watch</a><a href="//abc11.com/photos/">Photos</a><a href="//abc11.com/apps/">Apps</a></div><div class="footer-sections-group"><a href="//abc11.com/raleigh/">Raleigh</a><a href="//abc11.com/durham/">Durham</a><a href="//abc11.com/fayetteville/">Fayetteville</a><a href="//abc11.com/counties/">Surrounding Area</a></div></div><div class="footer-sections-col2"><div class="footer-sections-group"><a href="//abc11.com/us-world/">U.S. &amp; World</a><a href="//abc11.com/state/">North Carolina</a><a href="//abc11.com/iteam/">I-Team</a><a href="//abc11.com/troubleshooter/">Troubleshooter</a><a href="//abc11.com/entertainment/">Entertainment</a></div><div class="footer-sections-group"><a href="//abc11.com/about/">About ABC11</a><a href="https://abc11.com/share/">Send us your photos &amp; videos</a><a href="//abc11.com/together/">ABC11 Together</a><a href="//abc11.com/influencers/">ABC11 Influencers</a><a href="https://abc11.com/community/calendar/">Events Calendar</a><a href="//abc11.com/tvlistings/">TV Listings</a><a href="//abc11.com/jobs/">Jobs</a></div></div></div><div class="footer-legal"><div class="footer-legal-links" lpos="footer_legal"><ul class="footer-legal-links-mobile"><li><a href="https://disneyprivacycenter.com/">Privacy Policy</a></li><li><a href="https://privacy.thewaltdisneycompany.com/en/dnsmi/">Do Not Sell My Info</a></li><li><a href="https://disneyprivacycenter.com/kids-privacy-policy/english/">Children&#x27;s Privacy Policy</a></li><li><a href="https://disneyprivacycenter.com/notice-to-california-residents/">Your California Privacy Rights</a></li><li><a href="https://disneytermsofuse.com/">Terms of Use</a></li><li><a href="https://preferences.truste.com/2.0/?type=abc&amp;affiliateId=115">Interest-Based Ads</a></li><li><a href="https://publicfiles.fcc.gov/tv-profile/wtvd">Public Inspection File</a></li></ul><div class="footer-legal-links-col1"><a href="https://disneyprivacycenter.com/" target="_blank">Privacy Policy</a><a href="https://privacy.thewaltdisneycompany.com/en/dnsmi/" target="_blank">Do Not Sell My Info</a><a href="https://disneyprivacycenter.com/kids-privacy-policy/english/" target="_blank">Children&#x27;s Privacy Policy</a></div><div class="footer-legal-links-col2"><a href="https://disneyprivacycenter.com/notice-to-california-residents/" target="_blank">Your California Privacy Rights</a><a href="https://disneytermsofuse.com/" target="_blank">Terms of Use</a><a href="https://preferences.truste.com/2.0/?type=abc&amp;affiliateId=115" target="_blank">Interest-Based Ads</a><a href="https://publicfiles.fcc.gov/tv-profile/wtvd" target="_blank">Public Inspection File</a></div><div class="clear"></div></div><div class="footer-legal-copyright">Copyright © <!-- -->2020<!-- --> <!-- -->ABC, Inc., WTVD-TV Raleigh-Durham.<!-- --> All Rights Reserved.</div></div><div class="clear"></div></footer><div><script type='text/javascript'>
            (function(){var g=function(e,h,f,g){
            this.get=function(a){for(var a=a+"=",c=document.cookie.split(";"),b=0,e=c.length;b<e;b++){for(var d=c[b];" "==d.charAt(0);)d=d.substring(1,d.length);if(0==d.indexOf(a))return d.substring(a.length,d.length)}return null};
            this.set=function(a,c){var b="",b=new Date;b.setTime(b.getTime()+6048E5);b="; expires="+b.toGMTString();document.cookie=a+"="+c+b+"; path=/; "};
            this.check=function(){var a=this.get(f);if(a)a=a.split(":");else if(100!=e)"v"==h&&(e=Math.random()>=e/100?0:100),a=[h,e,0],this.set(f,a.join(":"));else return!0;var c=a[1];if(100==c)return!0;switch(a[0]){case "v":return!1;case "r":return c=a[2]%Math.floor(100/c),a[2]++,this.set(f,a.join(":")),!c}return!0};
            this.go=function(){if(this.check()){var a=document.createElement("script");a.type="text/javascript";a.src=g+ "&t=" + (new Date()).getTime();document.body&&document.body.appendChild(a)}};
            this.start=function(){var a=this;window.addEventListener?window.addEventListener("load",function(){a.go()},!1):window.attachEvent&&window.attachEvent("onload",function(){a.go()})}};
            try{(new g(100,"r","QSI_S_ZN_5hSLIyrLhlJ7ndr","//zn5hsliyrlhlj7ndr-abcotv.siteintercept.qualtrics.com/WRSiteInterceptEngine/?Q_ZID=ZN_5hSLIyrLhlJ7ndr&Q_LOC="+encodeURIComponent(window.location.href))).start()}catch(i){}})();
        </script>
        <div id="ZN_5hSLIyrLhlJ7ndr"></div></div><div>
<!-- Facebook Pixel Code -->
<script>
 !function(f,b,e,v,n,t,s)
 {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
 n.callMethod.apply(n,arguments):n.queue.push(arguments)};
 if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
 n.queue=[];t=b.createElement(e);t.async=!0;
 t.src=v;s=b.getElementsByTagName(e)[0];
 s.parentNode.insertBefore(t,s)}(window,document,'script',
 'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '454037632035460');
 fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1"
  src="https://www.facebook.com/tr?id=454037632035460&ev=PageView&noscript=1"/>
</noscript>
<!-- End Facebook Pixel Code --></div><div>
<script>
/*Copyright (c) 2011-2016 Moat Inc. All Rights Reserved.*/
function initMoatTracking(a,c,d,h,k){var f=document.createElement("script"),b=[];c={adData:{ids:c,duration:d,url:k},dispatchEvent:function(a){this.sendEvent?(b&&(b.push(a),a=b,b=!1),this.sendEvent(a)):b.push(a)}};d="_moatApi"+Math.floor(1E8*Math.random());var e,g;try{e=a.ownerDocument,g=e.defaultView||e.parentWindow}catch(l){e=document,g=window}g[d]=c;f.type="text/javascript";a&&a.insertBefore(f,a.childNodes[0]||null);f.src="https://z.moatads.com/"+h+"/moatvideo.js#"+d;return c};
</script></div><div data-box-type="fitt-adbox-adhesion"><div class="Ad ad-slot" data-slot-type="adhesion" data-slot-kvps="pos=adhesion"></div></div><div data-box-type="fitt-adbox-interstitial"><div class="Ad ad-slot" data-slot-type="interstitial" data-slot-kvps="pos=interstitial"></div></div><div></div></div></div></div>
                <script type='text/javascript' >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</script>
                <script type='text/javascript' >__CDN_PATH__="//assets-cdn.abcotvs.net/abcotv/3a89c23e7167-release-05-13-2020.2/client";</script><script type='text/javascript' src="//assets-cdn.abcotvs.net/abcotv/3a89c23e7167-release-05-13-2020.2/client/abcotv.js"></script><script type='text/javascript' src="//assets-cdn.abcotvs.net/abcotv/3a89c23e7167-release-05-13-2020.2/client/story.js"></script>
            </body>
        </html>
    